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Abstract

Printed electronics and low power radio has evolved signi�cantly in recent
years. This has made it possible to implement electronic worn on the body
or clothing.

Printed batteries internal resistance is much higher compared to regular bat-
teries. Unless a battery power management circuit is used, the radio peak
current makes that the terminal voltage may drop to a level below the speci-
�ed supply voltage for the radio, causing operation failure. A large capacitor
solves this but a large surface mounted capacitor can be both larger and
heavier than the integrated radio circuit. A trade-o� must be done. Voltage
regulation is necessary since the battery voltage is higher than the supply
voltage for the radio.

Design of capacitor, battery and low-dropout regulator were simulated in
the shape of function and life length in LTSpice. The results were compared
between theory, simulation and radio measurements.
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1 Introduction

1.1 Wearable electronics

Printed electronics has evolved rapidly in the last few years which has made
it possible to easily implement printed electronics in clothing and attached
to the body, especially in health care. Low power radio has also developed
rapidly and with small integrated circuits it has made it possible to make
these implementable with printed electronics. Electronics in clothing and
attached to the body is also called wearable electronics.

Electrodes have for example developed with printed electronics and become
handy to attach to the body in smooth stretch materials and together with
the implementation of small and low power radio devices it has become
possible to communicate wireless with these applications. These applications
become very �exible for both the user of the application and those who want
to access data from the application. These applications can also be used in a
loop system along with knowledge of medicine to try out the dosage of drugs
[28].

In this application is also printed batteries used for the application to be
partly so small, smooth and easy as possible, but also environmental friendly
according to the references [9, 10] compared to for example coin cell battery.

However, there are problems with printed batteries compared to regular bat-
teries which are developed with the same chemicals. In printed batteries are
internal resistance much higher than in regular batteries. Figure 1.1 shows
a typical situation for this application.
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Figure 1.1: Current consumption and voltage drop for a radio circuit

Typical values for the internal resistance of printed batteries are hundreds of
ohms. Typical values for low power radio peak current are tens of milliamps.
The terminal voltage can then decrease so much that the radio stops working.

Some form of power management to get the radio to work better at high
currents is needed.
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Figure 1.2: Prevent of voltage drop with a capacitor

If the circuit is dimensioned according to �gure 1.2 with a good sized ca-
pacitor circuit the radio will work better according to the dotted curve. A
surface mounted capacitor can be a quite big circuit compared to the radio
circuit. A trade-o� between the size in farad and size in terms of volume
and weight must be done.

Voltage regulation is also needed to be done to settle down the battery volt-
age to the input voltage level of the radio. In theory di�erent options of volt-
age regulation was planned like voltage regulation using low-dropout (LDO)
regulator and voltage regulation using DC1/DC-regulator of step-down type.
The good thing with a DC/DC-regulator of step-down type compared to a
LDO regulator is that the current consumption is lower because of a more ef-

1DC is short for Direct Current
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�cient regulator. This means that the terminal voltage dip could be less with
a DC/DC-regulator of step-down type compared to a LDO regulator. The
bad thing with a DC/DC-regulator of step-down type is that it need start
up time to stabilize and that it generates ripple on the output. LDO regula-
tion was realized with the integrated LDO regulator of the radio circuit used
in this application. DC/DC-regulator of step-down type was never realized
because the integrated DC/DC-regulator of step down-type was advised not
to be used [20, 23].

1.2 Overview existing solutions

Table 1.1 presents an overview of existing solutions including the application
this master thesis is about.

Company Product Power
source

Parameters Weight
[g]

Battery
life

[hours]

Sensium
Healthcare

Sensium
Vitals

Coin cell
battery

heart-rate,
respiration,
tempera-
ture

15 120

Delta Epatch Lithium-
ion

polymer
battery

electro-
cardiogram
(ECG)

16 72

Kiwok BodyKom Lithium-
ion

polymer
battery

ECG 37 30

KTH,
IPACK

Printed
health
monitor

Soft
battery
from

Enfucell

ECG,
respiration,
accelerom-

eter,
gyroscope

No
data

9

Table 1.1: Comparison between some existing solutions in health care

SensiumVitals is a wireless system that communicates wireless with the hos-
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pitals IT2 infrastructure to transfer measurement data. It uses coin cell
battery and the battery life is 120 hours and the weight of the patch is 15
gram [26].

EPatch records the measurement data that after recording is read out via
the USB3 interface. The next generation will read out measurement data
wireless via Bluetooth. It uses Lithium-ion polymer battery and the battery
life is 72 hours and the weight of the patch is 16 gram [11].

BodyKom records the measurement data that after recording is read out
via the USB interface. The next generation will read out measurement data
wireless via Bluetooth. It uses Lithium-ion polymer battery and the battery
life is 30 hours and the weight of the patch is 37 gram [2].

The Printed health monitor is a patch which is using Bluetooth Low Energy
(BLE) radio from Nordic Semiconductor to wireless communicate with for
example a smart phone to transfer measurement data [20, 23]. It uses printed
battery from Enfucell. Battery life is 9 hours according to measurements in
chapter 4.2 and 19 hours according to simulation in chapter 3.1 [10].

1.3 Problem to investigate in this project

• Get the radio to work at maximum current consumption.

• In hardware investigate how the radio could be as current e�cient as
possible.

• Investigate the life of the battery when the radio is working in a normal
way.

2IT is short for Information Technology
3USB is short for Universal Serial Bus
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2 Background

2.1 Power management

An embedded system is often consuming current in short connected modes,
in longer standby modes the system consumes very little current. When the
system is connected, the radio in the system sends and receives data and the
CPU is processing for example. In �gure 2.1 it is a more detailed schedule
about that.

Figure 2.1: Embedded system's current consumption and voltage drop

In �gure 2.1 is a typical situation for an embedded systems current consump-
tion described. In time period t1 the system is connected and consumes cur-
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rent and in time period t2 the system is in standby mode. It is possible to
prevent big voltage dip in terminal voltage (uL(t)) with a rather big capaci-
tor C according to �gure 2.1 and reduce the terminal voltage dip according
to the dotted curve for uL(t). But it is only possible to minimize the dips in
the terminal voltage around Udropaverage . Calculation of Udropaverage is done
according to equation 2.1.

Udropaverage = Iaverage ·Ri (2.1)

Calculation of Iaverage is done according to equation 2.2.

Iaverage =
Itopaverage · t1 + Istandby · t2

t1 + t2
(2.2)

Itopaverage is the average current for time period t1. According to equation
2.2 decrease of time period t1, increase of time period t2, decrease of current
Itopaverage and decrease of current Istandby will reduce current Iaverage.

2.2 Batteries

2.2.1 Chemical model

A battery consist in it's simplest form of an anode, a cathode and some
electrolyte as in �gure 2.2. When electric energy is taken from the battery
it converts chemical energy to electric energy and some of the chemicals
are consumed. To compare this with the electrical model in chapter 2.2.3
the internal resistance can be described as a sum of ionic resistance of the
electrolyte between the separator and the electrodes, electronic resistance of
the active mass, contact resistance between the electrode ends and the cur-
rent collector and contact resistance between the active material and current
collector [15]. The �gure 2.2 is taken from reference [7].
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Figure 2.2: Chemical model

Some theories about chemistry An atom is the smallest building block.
It's core consist of positively charged protons and uncharged neutrons. The
shell around the nucleus consist of negatively charged electrons.

All atoms or elements are structurally arranged in the periodic table where
one can deduce how many protons, neutrons, and electrons an element has.
In the periodic table the elements are placed by the atom number they have
that also tells how many protons or electrons an element has. The atomic
weight of a substance gives the number of neutrons and protons or number
of neutrons and electrons.

An element is dependent on the total number of electrons in di�erent shells.
The innermost shell closest to the nucleus can hold two electrons before it
is full. Shells outside can contain eight electrons before they are �lled with
some exceptions. In an element's outermost shell electrons are usually called
valence electrons.

An ion is an atom that has absorbed or shed electrons and thus become either
positively or negatively charged. Eg Zinc is a common element in batteries
which shed two electrons and then get the charge +2. It is common that two
materials are wanted with such a large voltage di�erence as possible, which
also becomes the cell voltage. The two materials act as electrodes where one
material is a negatively charged ion (cathode) and the other is a positively
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charged ion (anode) in an electrolyte [15].

Some common chemical reactions for primary cells

• Zinc/Manganese-Dioxide (nominal voltage 1,5V) [15, 29]:4

Anode:

Zn+ 2OH− → ZnO +H2O + 2e− (2.3)

Cathode:

2MnO2 +H2O + 2e− →MnOOH + 2OH− (2.4)

Overall:

Zn+ 2MnO2 +H2O → ZnO + 2MnO(OH) (2.5)

• Zinc/air (nominal voltage 1,4V) [15, 29]:

Anode:

Zn+ 2OH− + 2H2O → ZnO +H2O + 2e− (2.6)

Cathode:

O2 + 2H2O + 4e− → 4OH− (2.7)

Overall:

Zn+O2 + 2H2O → 2Zn(OH)2 (2.8)

4

Discharge=→
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• Zinc/Silver-oxide (nominal voltage 1,5V) [15, 29]:

Anode:

Zn+ 2OH− → Zn(OH)2 + 2e− (2.9)

Cathode:

Ag2O +H2O + 2e− → 2Ag + 2OH− (2.10)

Overall:

Zn+Ag2O → 2Ag + ZnO (2.11)

• Lithium/Manganese-Dioxide (nominal voltage 3,0V) [15, 29]:

Anode:

Li→ Li+ + e− (2.12)

Cathode:

MnO2 + Li+ + e− →MnOOLi (2.13)

Overall:

Li+MnO2 →MnOOLi (2.14)
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Some common chemical reactions for secondary cells

• Nickel/Metal-Hydride (nominal voltage 1,2V) [15, 29]:5

Positive electrode:

2NiOOH +H2O + e− � 2Ni(OH)2 +OH− (2.15)

Negative electrode:

Metal −H +OH− �Metal +H2O + e− (2.16)

Overall:

Metal −H + 2NiOOH �Metal + 2Ni(OH)2 (2.17)

• Lithium/Ion (nominal voltage 3,7V) [15, 29]:

Positive electrode:

Li1−x +Mn2O4 + Li+ + xe− � LiMn2O4 (2.18)

Negative electrode:

LixCn � nC + Li+ + xe− (2.19)

Overall:

Li1−x +Mn2O4 + LixCn � LiMn2O4 + nC (2.20)

5

Discharge=→, Charge=←
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2.2.2 Discharge model

The battery capacity is expressed in ampere hours [Ah] and is the amount of
charge available in the chemical active materials in the battery. The battery
capacity rating (C) is based on the battery manufacturers discharge curves
from their discharge test of a battery.

Discharging proceeds at constant current until the battery voltage drops
to a �nal value, End of Discharge Voltage (EoDV) as shown in �gure 2.3.
The discharge curve midpoint is called Midpoint Voltage (MPV) as shown in
�gure 2.3 and it is this value of voltage which is usually listed as the terminal
voltage.

It is common to indicate the discharge time with the capacity rating index
(Cindex).

I =
Cindex

index
(2.21)

The discharge current is capacity divided by the discharge time [3].

Figure 2.3: Discharge model

Discharge current The battery capacity depends on size or how big
area a chemical material has and how much available chemical material or
the chemical material density. Battery capacity also depends on type of
material.
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The battery capacity also depends on how the discharge is done. High dis-
charge current reduce the battery capacity as shown in �gure 2.3. High
current cause losses in the battery's internal resistance. Low discharge cur-
rent increase the battery capacity as shown in �gure 2.3 [3].

Battery temperature The electrochemical processes in a battery is tem-
perature dependent. At low temperature the battery can only deliver a part
of the delivery in normal temperature as shown in �gure 2.3. With increasing
temperature the electrochemical processes will be faster which increase the
capacity but self-discharge is also increased at higher temperature as shown
in �gure 2.3 [3].

2.2.3 Electrical model

Look at �gure 2.4. Terminal voltage is what you can measure outside the
battery. If a load is connected to the battery will the battery current (I)
cause a voltage drop over the internal resistance (Ri) and the terminal voltage
(U) will become lower than the electromotive force (E). Kircho�s voltage
law says

U = E − I ·Ri (2.22)

If the expression is multiplied with I the expression will be between three
power terms which is

I · U = I · E − I2 ·Ri (2.23)

The power from the battery is I · U . The chemical energy in the battery is
I · E. The power loss in the battery is I2 ·Ri [3].
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Figure 2.4: Electrical model

This is a very simple and linear electrical model of a battery, and a battery is
not linear. A more advanced and nonlinear model of the battery is presented
in chapter 3.1 where the voltage source E in �gure 2.4 is modeled as the
discharge model in chapter 2.2.2. The goal is that the total model will be
equivalent with the chemical model in chapter 2.2.1.

2.2.4 Printed batteries

Look at �gure 2.5.

Figure 2.5: Printed battery

Functional layers are placed between two carrier foils. The functional layers
are current collector, anode, cathode, and a separator. The separator layer
is central when it should let through the ion transport but not have direct
contact between the anode and the cathode layer as a short circuit. A
common solution is that the separator is soaked with an electrolyte. A seal
preventing water vapor is necessary to keep the layer humid. Here a trade-o�
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must be done to avoid short circuits with too thin electrolyte layer and high
internal resistance with too thick electrolyte layer.

Same chemistry is used for regular batteries. To manufacture a cell with
printing technologies, all layers must be available as printing inks (pastes)
[29]. Also the processing methods are important and have lately been im-
proved.

Figure 2.6: Printing process

Direct write printing is a simple method for printing inks at room tempera-
ture. If you compare with micro-fabrication techniques, which use processes
such as lithography and etching, it is less process steps and generated waste
according to �gure 2.6 [13]. The �gure 2.6 is taken from reference [13].

To refer to chapter 2.2.1 the simplest system to manufacture is Zinc/Manganese-
Dioxide with chemistry formula 2.5.

Systems that contain Lithium can be di�cult and dangerous to handle. Ex-
amples of such systems containing Lithium can be with chemistry formulas
2.14 and 2.20.

Zinc/Air with chemistry formula 2.8 can be di�cult to fabricate the air
electrode.
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Zinc/Silver-oxide with chemistry formula 2.11 and Nickel/Metal-hydride with
chemistry formula 2.17 can have a little di�cult fabrication of the electrolyte
which is strongly alkaline.

Two design types are common when printed batteries are fabricated, stack
or sandwich type and co-planar type [29].

Figure 2.7: Stack or sandwich type

The stack or sandwich type in �gure 2.7 need more layers but can handle
much higher charge and discharge currents.
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Figure 2.8: Co-planar type

The co-planar type in �gure 2.8 need less layers but can only handle small
charge and discharge currents.
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Figure 2.9: Printed battery process

In �gure 2.9 a sequence in steps to produce a printed battery of a stack type
is shown. To keep the cell humid the whole life time a seal must encapsulate
it as in step c in �gure 2.9. In step f in �gure 2.9 one half is folded over the
other and the seal is enclosed with heat [29]. The �gures 2.5, 2.7, 2.8 and
2.9 are taken from reference [29].

Table 2.1 lists several manufacturers of printed batteries.
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Manufacturer Enfucell Bluespark ST Microelec-
tronics

Product name Soft battery
Mini

103-UTI EFL700A39

Dimension
(Height
/Length

/Thickness)
[mm]

36/46/0,7 30/40/0,5 25,7/25,7/0,22

Weight [g] 0,9 No data 0,2

Design type Co-planar Co-planar No data

Operative
temperature

range
(min/max)

[◦C]

-35/50 -30/65 -20/60

Material Zinc/
Manganese
Dioxide

Zinc/
Manganese
Dioxide

Lithium/Ion

Eco friendly Yes Yes No

Rechargeable No No Yes

Nominal
voltage [V]

1,5 1,5 3,9

Capacity
[mAh]

18 10 0,7

Internal
resistance
[ohm]

150 No data 100

Shelf life time
[years]

2 No data 10

Table 2.1: Printed battery's manufacturer

It is a trade-o� between several parameters to choose a manufacturer. En-
fucell has been chosen in this thesis application [10]. Comparing Enfucell
and Bluespark one can see that they have similar strengths and weakness.
There is no data found for internal resistance for Bluespark which is a weak-
ness [1]. Comparing Enfucell and ST Microelectronics there is a trade-o�
between several parameters. For example ST Microelectronics battery is
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rechargeable but with very low capacity compared to Enfucell. On the other
hand is Enfucell eco friendly compared to ST Microelectronics [6].

2.2.5 Regular batteries

The internal resistance of a battery is dependent on the speci�c battery's
size, chemical properties, age, temperature and the discharge current. In
printed batteries as described in chapter 2.2.4, the high internal resistance
is often a problem. Compared to regular batteries have printed batteries
simply less volume which is one reason why the internal resistance is higher
in printed batteries.

Below are some common descriptions of batteries of di�erent chemistry for-
mulas according to chapter 2.2.1 described.

Zinc/Manganese-Dioxide are mainly single use batteries, which have a short
life-cycle. A single Zinc/Manganese-Dioxide dry cell has low environmental
impact on disposal.

Zinc/air has high energy density and is relatively inexpensive to produce.

Compared to other batteries Zinc/Silver-oxide has a higher open circuit po-
tential and a �atter discharge curve than a standard alkaline battery.

Lithium/Manganese-Dioxide has good performance over a wide temperature
range, long shelf life, storability even at elevated temperatures, and low cost.

The typical speci�c energy for small Nickel/Metal-Hydride cells is about the
same as lithium/ion. The signi�cant disadvantage of Nickel/Metal-Hydride
batteries is the high rate of self-discharge.

Lithium/Ion are common types of rechargeable batteries with a high energy
density, long shelf life and low self-discharge rate [15].

2.3 Power regulation

Figure 2.10 shows e�ciency over output current for the LDO regulator
LT1761-1.8 (red curve) and the DC/DC-converter of step-down type LTC3405A-
1.8 (black curves).

Figure 2.10 is taken from the data sheet of the LTC3405A-1.8 according to
reference [17] with e�ciency of the LDO regulator LT1761-1.8 added.

To calculate e�ciency for the LDO regulator LT1761-1.8 the equation 2.27
was used with data for Iquiescent from reference [16]. Output voltage for both
the LDO regulator and the DC/DC-converter of step-down type is 1,8V.
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Figure 2.10: E�ciency for a LDO regulator versus a DC/DC-converter of
step-down type

2.3.1 Low-dropout regulator

In a low-dropout (LDO) regulator the principle is that a varying input volt-
age is taken up by the series element and deliver a constant output voltage
with nearly the same input current as output current.

In it's simplest form it can be arranged by a feedback coupled operational
ampli�er as fault ampli�er with a reference voltage source at one of it's
inputs. The output of the operational ampli�er is connected to the gate of
a �eld e�ect transistor (FET) with it's drain as input voltage and with it's
source as output voltage for the LDO regulator as shown in �gure 2.11.
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Figure 2.11: A simple LDO regulator

A LDO regulator is a fast regulator compared to for example a DC/DC-
converter of step-down type which need some start-up time. The problem
with a LDO regulator is the loss of power and the e�ciency. Input power
can be expressed as

Pin = Uin · (Iout + Iquiescent) (2.24)

Quiescent current (Iquiescent) is the supply current the LDO regulator re-
quires. If a FET is used as in �gure 2.11, the quiescent current is almost
constant.

Output power can be expressed as

Pout = Uout · Iout (2.25)

Power loss will then be

Ploss = Pin − Pout = (Uin − Uout) · Iout + Uin · Iquiescent (2.26)

and the e�ciency will be
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η =
Pout

Pin
=

Uout · Iout
Uin · (Iout + Iquiescent)

(2.27)

The quiescent current is a quite small current and at higher current will the
input current be almost the same as the output current.

η =
Uout

Uin
(2.28)

The e�ciency is then only a relation between input and output voltage ac-
cording to equation 2.28 [19].

2.3.2 DC/DC-converter of step-down type

A DC/DC-converter of step-down type or buck type converts input voltage
Uin to a lower output voltage Uout as shown in �gure 2.12. The voltage
across the capacitor (C) is given by

q = C · u (2.29)

and the current through the capacitor can be expressed as the derivative of
the charge with respect to time according to

i =
dq

dt
(2.30)

which gives the expression

i = C · du
dt

(2.31)

If i=0 there is no change of the voltage across the capacitor. If i=constant
the change of the voltage across the capacitor is linear. The current through
the coil (L) is given by

Φ = L · i (2.32)

and the voltage across the coil can be expressed as the derivative of the �ow
with respect to time according to

u =
dΦ

dt
(2.33)

which gives the expression

u = L · di
dt

(2.34)
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If u = 0 there is no change of the current through the coil. If u = constant
the change of the current through the coil is linear. The voltage over the
inductor is the AC6 voltage part. The voltage over the capacitor is the DC
voltage part. The change of charge is expressed asˆ T

0
iCdt = 0 (2.35)

The change of �ow is expressed asˆ T

0
uLdt = 0 (2.36)

Uout will be like the DC voltage part of us according to

Uout =
1

T

ˆ T

0
usdt =

UinδT

T
= Uinδ (2.37)

The parameter δ is the duty cycle.

The power e�ciency can be expressed as:

η =
Pout

Pin
=
Uout · Iout
Uin · Iin

(2.38)

Assume that the DC/DC converter of step-down type is loss-less and that
η = 100%. If equation 2.37 and equation 2.38 is combined it gives the
following expression:

Iin = Ioutδ (2.39)

According to equation 2.39 and compared with the LDO regulator, it is
possible to get lower input current.

But this is when the DC/DC-converter of step-down type has an e�ciency
of 100%.

6AC is short for Alternating Current
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Figure 2.12: A simple DC/DC-converter of step-down type

Often, instead of the switch and diode in �gure 2.12, are the metal oxide
semiconductor �eld e�ect transistors (MOSFET) used.

It is because they are more e�cient but there are also losses in them.

The three most common causes of power losses in a DC/DC-converter of
step-down type are:

• Inductor conduction losses

• MOSFET conduction losses

• MOSFET switching losses

A DC/DC-converter of step-down type is more power e�cient than a LDO
regulator. But it is also slower because it needs start-up time before the
output voltage is stabilized and it also generates a voltage ripple at the
output, which can be a problem because some circuits are sensitive to it
[4, 19].

2.3.3 Conclusion power regulation

As has been seen in �gure 2.10 the e�ciency is better with a DC/DC-
converter of step down-type than a LDO regulator. It has also been seen
that a DC/DC-converter of step-down type need start-up time before the
output voltage is stabilized and it also generates a voltage ripple on the
output. In this thesis, the focus was �rst to get the radio to work with max-
imum power. The goal was reached with the internal LDO regulator in the
nRF51822 circuit. Because of this, no further investigations were made with
the DC/DC-converter of step-down type.
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3 Design & implementation

3.1 Battery model

To be able to simulate a manufacturer's discharge curve, a known battery
model was used as reference. It was building on the discharge model in
chapter 2.2.2 and the electrical model in chapter 2.2.3 to be as equal as
possible to the chemical model in chapter 2.2.1.

This model was simpli�ed to the model in �gure 3.1. To simulate a simulation
program called LTSpice was used. For further information about LTSpice
see [18]. For further information about the simulations in this report see
appendix A.

Figure 3.1: Circuit for the battery model

In �gure 3.1 is the non-linear voltage controlled voltage source (VCVS) like
the discharge model in chapter 2.2.2. The speed of the state of charge (SOC)
is decided by the capacitor and the current controlled current source (CCCS).

The capacitor is the capacity in hours of the battery according to equation
3.1. Fudge factor in the equation 3.1 is used to adjust the cuto� voltage
with the remaining capacity of the manufacturer's discharge curve and the
simulated capacity of 0V at 0% remaining capacity, for further information
see reference [12].
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C = 3600 · CAPACITY · FUDGEFACTOR (3.1)

In the circuit for the battery model in �gure 3.1 the resistor (R) is represent-
ing the battery's shelf life time and is dependent of the shelf life time and the
capacity. The shelf life time is the time in years when the terminal voltage
has decreased to 90% depending of self-discharge and can be described by
equation 3.2.

0, 9 = e−
τ
R·C = e−

365·24·SHELFLIFETIME
R·CAPACITY (3.2)

Take the natural logarithm on both sides of the equation 3.2, and solves with
respect to R gives the equation 3.3.

R ≈
365 · 24 · SHELFLIFETIME

0, 105 · CAPACITY
(3.3)

The resistor Ri in the circuit for the battery model in �gure 3.1, represents
the internal resistance of the battery.

The CCCS is a current source with the same current as the current (I)
�oating through the battery when a load is connected between anode and
cathode.

In the simulation, the voltage (SOC) of the capacitor is set to 1V initially and
then discharged down to 0V at a rate depending on the capacity parameter
and the current (I) according to �gure 3.3.

The non-linear VCVS is modeled with a look-up table with SOC on the x-axis
and discharge data from the battery manufacturer on the y-axis. The values
between 1V and 0V are translated in to the look-up table to the terminal
value at a certain SOC. The SOC is calculated according to equation 3.4:

SOC = 1− time

timecutoffvoltage
(3.4)

Data parameters capacity, shelf life, internal resistance and discharge data
should be possible to �nd from the battery manufacturer.

For further information see reference [12]. The simulation in LTSpice of the
battery model can be found in chapter A.1 in appendix A and the look-up
table can be found in chapter A.5 in appendix A.
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In �gure 3.2 is a circuit to test data in reference [8] with a terminal voltage
of 1,5V and a load of 10kΩ and parameters from reference [10].

Figure 3.2: Circuit for the Enfucell battery test

Figure 3.3 shows the discharge simulation of the Enfucell mini battery which
should be compared with reference [8].

According to the theory in chapter 2.2.2 the EoDV is at the point when the
voltage over the capacitor in �gure 3.1 is 0V and according to �gure 3.3 it
is after ca 135 hours. According to the same theory in chapter 2.2.2 the
MPV is at a point where the curve is rather �at and the voltage is then ca
1,25V which is di�erent compared to the nominal voltage of 1,5V stated in
reference [10].

The simulation in LTSpice of the battery test of the Enfucell battery can be
found in chapter A.2 in appendix A.
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Figure 3.3: Simulated discharge curve for the Enfucell battery test

A simulation was also done on the battery life with a simpli�ed model of
the actual system in �gure 3.4. Because it was not possible to get data for
the built in LDO regulator in the nRF51822 circuit a LDO regulator was
used from the company Linear Technology who has developed LTspice. The
LDO regulator had a spice model and should have similar data as the built
in LDO regulator, for further information see reference [16].

Figure 3.4: Circuit for the battery life test

The simulation in �gure 3.5 should be compared with measurement data in
�gure 4.12. Consider a simple comparison between simulation in �gure 3.5
and theory in equation 3.5 which is building of theory in equation 2.21 in
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chapter 2.2.2.

index =
Cindex

I
=

18 · 10−3

1 · 10−3
= 18hours (3.5)

The current in the theory is approximated to 1mA and is a sum of the
current consumption for the gyroscope, the accelerometer, the analog to
digital converter and the radio as a current source, for further information
see chapter 4.1. In the circuit in �gure 3.4 current through resistor RL will
decrease when the terminal voltage of the batteries decreases, which explains
the simulation of 19 hours compared with the theory of 18 hours.

The simulation in LTSpice of the battery life can be found in chapter A.3 in
appendix A.

Figure 3.5: Simulated discharge curve for the battery life test

3.2 Radio power management

The nRF51822 is a System on Chip (SoC) circuit which can be used for
Bluetooth applications and 2.4GHz low-power wireless applications. It has
built in power management in form of a LDO regulator and a DC/DC-
converter of step-down type. Unfortunately it is only possible to use the
LDO regulator or both the LDO regulator and the DC/DC-converter of step-
down type, not only the DC/DC-converter of step-down type. Also because
of the recommendation not to use the DC/DC-converter of step-down type
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with the BLE S110 soft device and the conclusions in chapter 2.3.3 was no
testing of the DC/DC-converter of step-down type performed.

Power management in the nRF51822 has two modes which is system on and
system o�. In documentation for the BLE S110 soft device it is possible to
�nd a more detailed description when the device is in mode system on and
connected, for further information see [24]. In �gure 3.6 it is described how
a typical current pro�le event looks like for mode system on and connected.
The �gure 3.6 is taken from reference [24].

Figure 3.6: Current pro�le for the nRF51822

In table 3.1 a more detailed description is shown for the shown stages marked
with letters in �gure 3.6 and how to calculate current consumption with
current parameters which can be found in reference [23].
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Stage Description Current consumption

(A) Preprocessing ION + IRTC + IX32k + ICPU,F lash

(B) Standby +
XO ramp

ION + IRTC + IX32k + ISTART,X16M

(C) Standby ION + IRTC + IX32k + IX16M

(D) Radio Start ION + IRTC + IX32k + IX16M +
´

(ISTART,RX)

(E) Radio RX ION + IRTC + IX32k + IX16M + IRX + ICRY PTO

(F) Radio
turn-around

ION + IRTC + IX32k + IX16M +
´

(ISTART,TX)

(G) Radio TX ION + IRTC + IX32k + IX16M + ITX,0dBM +
ICRY PTO

(H) Post-
processing

ION + IRTC + IX32k + ICPU,F lash

(I) Idle -
connected

ION + IRTC + IX32k

Table 3.1: Stage description and current consumption

In �gure 3.7 the possible states for the state machine of the radio is shown.
The �gure 3.7 is taken from reference [20].

Figure 3.7: State machine for the nRF51822

In table 3.2 a description is shown for the di�erent states shown in �gure
3.7. For further information see [20].
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State Description

DISABLED No operations are going on inside the radio and the
power consumption is at a minimum.

RXRU The radio is ramping up and preparing for reception.

RXIDLE The radio is ready for reception to start.

RX Reception has been started and the addresses enabled
in the RXADDRESSES register are being monitored.

TXRU The radio is ramping up and preparing for
transmission.

TXIDLE The radio is ready for transmission to start.

TX The radio is transmitting a packet.

Table 3.2: State description

To compare stages in �gure 3.6 with states in �gure 3.7 it is shown that there
is no radio activity in stage (A), (B) and (C), which means that the radio
is in state DISABLED. In stage (D) the radio goes from state DISABLED
through state TXRU to state TXIDLE. In stage (E) the radio goes from state
TXIDLE to state TX. In stage (F) the radio goes from state TX through
states TXDISABLE, DISABLED and RXRU to state RXIDLE. In stage (G)
the radio goes from state RXIDLE to state RX. In stage (I) the radio goes
from state RX through state RXDISABLE to state DISABLED.

3.3 Power simulation

In this chapter it is described how to simulate the system according to the
measurements of functionality test in chapter 4.1. Figure 3.8 shows a simu-
lation model of the actual system.
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Figure 3.8: Circuit for the functionality test

Figure 3.9 shows the simulation of terminal voltage, current consumption
for the radio and output voltage for the LDO regulator which should be
compared with measurement data in �gure 4.9. The simulation in LTSpice
of the functionality test can be found in chapter A.4 in appendix A.

Figure 3.9: Simulated voltage and current over time for the functionality
test

3.4 Sizing of capacitors

As has been seen in chapter 2.1 it is possible to prevent voltage dip with
a rather big capacitor. Below are the steps for the sizing of a capacitor.
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Consider the �gure 3.10 with a resistance, a capacitor and a voltage source
with the belonging voltage over time diagram.

Figure 3.10: A simple charge/discharge circuit

The capacitor is discharged under the time t1 to the voltage level u2 according
to �gure 3.11. The capacitor is charged under the time t2 to the voltage level
u1 according to �gure 3.11.

Figure 3.11: A simple charge/discharge curve

The voltage level between u1 and u2 at discharging is called ∆u1. The voltage
level between u1 and u2 at charging is called ∆u2.

The signing of u1 and u2 under discharging gives:

u1 = f1(t0) = e−
t0
R·C (3.6)

u2 = f1(t0 + t1) = e−
t0+t1
R·C = e−

t0
R·C e−

t1
R·C (3.7)
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∆u1 = u1 − u2 (3.8)

Combining equation 3.6 and 3.7 gives:

u2 = u1e
− t1
R·C (3.9)

Combining equation 3.8 and 3.9 gives:

∆u1 = u1(1− e−
t1
R·C ) (3.10)

Signing of u1 and u2 under charging gives:

u1 = f2(t3) = 1− e−
t3
R·C (3.11)

u2 = f2(t3 − t2) = 1− e−
t3−t2
R·C = 1− e−

t3
R·C e

t2
R·C (3.12)

∆u2 = u1 − u2 (3.13)

Combining equation 3.11 and 3.12 gives:

u2 = 1− (1− u1)e
t2
R·C (3.14)

Combining equation 3.13 and 3.14 gives:

∆u2 = u1 − (1− (1− u1)e
t2
R·C ) = u1(1− e

t2
R·C ) + e

t2
R·C − 1 (3.15)

When charging and discharging is of same size:

∆u = ∆u1 = ∆u2 (3.16)

Combining equation 3.10, 3.15 and 3.16 gives:

u1 =
e
t2
R·C − 1

e
t2
R·C − e−

t1
R·C

(3.17)

Combining equation 3.14 and 3.17 gives:

u2 =
e−

t1
R·C (e

t2
R·C − 1)

e
t2
R·C − e−

t1
R·C

(3.18)

In this application there is also a radio with current consumption illustrated
in �gure 3.12 by a current source and some current consuming units modeled
by a resistance RL, for further information see chapter 4.1:
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Figure 3.12: A Thevenin circuit for the radio

Transformation of the voltage source in �gure 3.12 from Thevenin equivalent
to Norton equivalent gives the appearance in �gure 3.13.

Figure 3.13: A Norton circuit for the radio

Adding the two current sources in �gure 3.13 gives the appearance in �gure
3.14.

Figure 3.14: A simpli�ed Norton circuit

Transformation of the current source in �gure 3.14 from Norton equivalent
to Thevenin equivalent gives the appearance in �gure 3.15.
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Figure 3.15: A simpli�ed Thevenin circuit

Considering the belonging current and voltage over time for �gure 3.15 in
�gure 3.16:

Figure 3.16: Voltage and current over time for the radio

Comparing �gure 3.16 with �gure 3.10 it is easy to see that the di�erence is
that the voltage is changing from RL

Ri+RL
(u(t)−i(t)·Ri) to

RL
Ri+RL

u(t) instead
of changing from 0 to 1 when changing time from t1 to t2. Comparing �gure
3.15 with �gure 3.10 it is also easy to see that R = Ri·RL

Ri+RL
. Resigning of

equation 3.17 and 3.18 with this new model behavior will looks like:

u1 =
RL

Ri +RL
(i(t) ·Ri

e

t2
Ri·RL
Ri+RL

·C − 1

e

t2
Ri·RL
Ri+RL

·C − e
− t1

Ri·RL
Ri+RL

·C

+ u(t)− i(t) ·Ri) (3.19)

u2 =
RL

Ri +RL
(i(t) ·Ri

e
− t1

Ri·RL
Ri+RL

·C
(e

t2
Ri·RL
Ri+RL

·C − 1)

e

t2
Ri·RL
Ri+RL

·C − e
− t1

Ri·RL
Ri+RL

·C

+ u(t)− i(t) ·Ri) (3.20)

In �gure 3.17 is a typical appearance of the terminal voltage over time with
a rather big capacitor according to �gure 3.12 described.
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Figure 3.17: Ripple around average voltage drop

To dimension a rather big capacitor according to �gure 3.12 an approxima-
tion can be done. The average current can be calculated according to �gure
3.16 with following expression:

Iaverage =
1

T

ˆ T

0
i(t) · dt =

Itop · t1
t1 + t2

(3.21)

Calculation in average how much the terminal voltage will drop according
to �gure 3.17:

Udropaverage =
RL

Ri +RL
u(t)− Ri ·RL

Ri +RL
Iaverage (3.22)

Calculation of dU according to �gure 3.17 using equation 2.31 can be done.
If equation 2.31 is rewritten according to C it gives following expression:

C = i · dt
du

(3.23)

The voltage di�erence du is approximately 50% over and under the Udropaverage

with a rather big capacitor according to �gure 3.17 which gives the following
equation:

du

2
= u1 − Udropaverage = Udropaverage − u2 (3.24)

In this application a decision of how much the terminal voltage is allowed
to drop will be taken, i.e. a value of u2. Then it is possible to calculate
capacitor value C with equation 3.21, 3.22, 3.23 and 3.24.
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4 Measurements

The measurements in this chapter are based on the conclusions in chapter
1.3.

To start measurements the list with instruction 1-11 was followed �rst.

1. Install software according to [21].

2. Connect the nRF51822 development kit PCB7 antenna module PCA10004
according to �gure 4.2.

3. Connect the J-Link Lite CortexM-9 JTAG8/SWD9 emulator according
to [21].

4. Compile heart rate application in Keil according to [21].

5. Program soft device in nRFgo studio according to [21].

6. Program heart rate application in nRFgo studio according to [21].

7. Disconnect the nRF51822 development kit PCB antenna module PCA10004
and the J-Link Lite CortexM-9 JTAG/SWD emulator.

8. Connect the nRF51822 development dongle PCA10000 to install and
program it according to [21].

9. Connect the nRF51822 development kit PCB antenna module PCA10004
according to �gure 4.2.

10. Start Master Control Panel according to [21] and scan for available
BLE device according to [21].

11. In Master Control Panel enter connected mode according to [21].

An overview of all software and hardware needed for the instruction list is
shown in �gure 4.1. The �gure 4.1 is taken from reference [21].

7PCB is short for Printed Circuit Board
8JTAG is short for Joint Test Action Group
9SWD is short for Serial Wire Debug
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Figure 4.1: Test setup for the nRF51822 development kit

4.1 Functionality test

Figure 4.2 shows the measurement circuit to measure current consumption
(K2), terminal voltage and output voltage from LDO regulator (DEC2). The
current consumption was measured also as reference to �nd the minimum
terminal voltage.
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Figure 4.2: Test circuit functionality test

Table 4.1 explains in more detail a certain block in �gure 4.2.

Block Description References

Radio nRF51822 Development Kit [21]

Battery Enfucell soft battery mini, E=1,5V,
Ri=150ohm

[10]

Oscilloscope TDS3054, Tektronix [27]

Voltage
probe

TEK P6139A voltage probe, Tektronix [27]

Table 4.1: Detailed block description

RL in �gure 4.2 simulates load for gyroscope, accelerometer and analog to
digital converter on the real board. The circuit which is used as gyroscope
and accelerometer is LSM330 with current consumption 250µA. Further
information about the circuit can be found in [5]. The circuit which is used
as analog to digital converter is ADS1292R with current consumption 280µA.
Further information about the circuit can be found in [25]. Calculation of
the load is done by equation 4.1:

RL =
u(t)

ILSM330 + IADS1292R
=

3

250 · 10−6 + 280 · 10−6
≈ 5, 66kΩ (4.1)
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Choosing RL = 5, 6kΩ gives some margin for the total current consumption
for the both circuits.

The heart rate application was running on the radio (nRF51822 development
kit PCB antenna module PCA10004) under the test. The nRF51822 devel-
opment dongle PCA10000 was used to force the radio in connected mode.
Between every 17,75ms packet data of 2,25ms was sent in this application.

The trigger level of the oscilloscope was set to 1,2V on the channel which
was measuring the current consumption with a factor 100 through a current
shunt monitor in contact K2. The current shunt monitor is shown in �gure
4.3. The �gure 4.3 is taken from reference [14].

Figure 4.3: Current shunt monitor for the nRF51822 development kit

The circuit used on the radio is INA216A4 and the shunt resistor has the
value of two 1ohm resistors in parallel on the radio.

However the current measurement was very uncertain and because of that
the current was also measured after the components C7 and C12 marked in
�gure 4.4 were removed. The �gure 4.4 is taken from reference [22].
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Figure 4.4: Marked circuits removed for the current measurement

The current was then measured over a 15ohm resistance called R in �gure
4.5 connected between power source and input voltage for the circuit.

Figure 4.5: Test circuit for the current measurement
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Table 4.1 explains in more detail a certain block in �gure 4.5.

In �gure 4.6 a plot of the current consumption is shown with numbered
stages in red.

Figure 4.6: Radio current over time

A comparison between the �gure 4.6 and �gure 3.6 takes place in the ta-
ble 4.2 with current consumption measured and calculated according to the
table 3.1 with data from reference [23]. There is also a column of current
consumption data read out from �gure 3.6 in table 4.2. If a comparison is
made between current consumption calculated according to table 3.1, and
current consumption read from the �gure 3.6, one can see that there is a
di�erence. It is not clear why there are some di�erence between these theory
alternatives.
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Figure
4.6

Figure
3.6

Calculated
current

consumption
according to

table 3.1 with
data from [23]

[mA]

Current
consumption
read out from
�gure 3.6 [mA]

Current
consumption
according to

measurements
in �gure 4.6

[mA]

(1) (A) 4,40 5,27 5,00

(2) (B) 1,10 2,18 1,50

(3) (C) 0,47 0,00 0,00

(4) (D) 9,17 11,27 8,00

(5) (E) 14,27 13,82 13,75

(6) (F) 7,47 9,64 9,00

(7) (G) 11,37 11,64 12,00

(8) (H) 4,40 4,91 4,00

(9) (I) 0,00 0,00 0,00

Table 4.2: A comparison of stage and current for measurement versus theory

But it seems that measured current consumption is somewhere around both
the theoretical alternatives. Note that measured current consumption can
di�er because of measurement uncertainty when measuring fast changes in
value of the current consumption.

To calculate Iaverage equation 3.21 is used. This calculation can be done in
two ways. The plot of �gure 4.6 and 4.8 is based from 10000 data points
saved in a comma separated values (CSV) �le.

The �rst alternative is to summarize every 10000 current values from data
in �gure 4.6 and divide with 50000 because one period is 20ms and data in
�gure 4.6 is 4ms long and the missing 16ms is with zeros for the current
value.

The second alternative is to summarize every 10000 current values from data
in �gure 4.8 and divide with 10000 because data in �gure 4.8 is 40ms long
which is exactly two periods.

To make it easier to calculate the theory, a calculation of Itopaverage according
to theory in chapter 2.1 is done. This is more tricky to do because the �rst
point in stage (1) and last point in stage (8) in �gure 4.6 must be found
to calculate the �rst alternative. The �rst and last point for one of the two
current bursts in �gure 4.8 must be found to calculate the second alternative.
For both alternatives the current values is summarized and then divided by
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the number of data points between the �rst and last point. In table 4.3 a
presentation is done for alternative one and two for both average current and
average top current. In table 4.3 a presentation is also done for the average
current and the average top current calculated according to table 3.1 and
the average current and the average top current read out from �gure 3.6.

Parameters Average
current
[mA]

Average top
current
[mA]

Alternative one 0,39 3,5

Alternative two 0,39 3,5

Calculated current consumption
according to table 3.1 with data

from [23]

0,38 3,4

Current consumption read out from
�gure 3.6

0,44 3,9

Table 4.3: Calculation of average current

In �gure 4.7 a plot of terminal voltage and output voltage from LDO regu-
lator is shown.

Figure 4.7: Terminal and LDO voltage over time
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In �gure 4.8 a more zoomed out plot over two periods, of current consumption
is shown.

Figure 4.8: Radio current over two periods

In �gure 4.9 a more zoomed out plot over two periods, of terminal voltage
and output voltage from LDO regulator is shown. Comparing �gure 4.9 with
simulation in �gure 3.9 shows similar curve forms. The di�erence between
LDO voltage in simulation and measurement can be explained by measure-
ment uncertainty when measuring fast changes in value of the LDO voltage.
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Figure 4.9: Terminal and LDO voltage over two periods

Table 4.4 shows parameters from some measurements with di�erent size of
capacitors. The maximum terminal voltage parameter is u1 and the mini-
mum terminal voltage parameter is u2 according to �gure 3.17.

Figure 4.7 and �gure 4.9 shows data from row three in table 4.4.

C [µF ] RL [kΩ] Maximum terminal
voltage [V]

Minimum terminal
voltage [V]

100 5,6 2,77 2,67

220 5,6 2,75 2,70

1000 5,6 2,74 2,71

Table 4.4: Measured terminal voltage for di�erent capacitors

To compare the measured results with theory a presentation of the calculated
data with equation 3.19 and 3.20 is shown in table 4.5.

C [µF ] RL [kΩ] Ri [Ω] I [mA] t1 [ms] t2 [ms] u1 [V] u2 [V]

100 5,6 300 3,5 2,25 17,75 2,77 2,70

220 5,6 300 3,5 2,25 17,75 2,75 2,72

1000 5,6 300 3,5 2,25 17,75 2,74 2,73

Table 4.5: Calculated terminal voltage for di�erent capacitors
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The measurement result in table 4.4 compared with theory in table 4.5 shows
some di�erences for value u2 which can be explained by measurement uncer-
tainty. It also shows that it is of course necessary with a rather big capacitor
in the circuit. However it is shown in �gure 3.17 that the average current
and internal resistance in battery, limits the terminal voltage to a certain
level. Because of that, it is only possible to minimize the ripple around that
level with the size of the capacitor. According to the theory in chapter 3.4
it is possible to calculate that level with equation 3.22.

Udropaverage =
5, 6 · 103

300 + 5, 6 · 103
·3− 300 · 5, 6 · 103

300 + 5, 6 · 103
·0, 39·10−3 = 2, 74V (4.2)

According to table 4.5, one should choose a capacitor of 1000µF before 220µF
but the size of a surface mounted capacitor can di�er a lot between 1000µF
and 220µF. A trade-o� between size in Farad and size and weight must be
done.

4.2 Discharge curves, battery life

To test the battery life for the application an already existing LabVIEW
program was used which could save present oscilloscope pictures for a cer-
tain channel (Textronix TDS 3000 Series Transfer Current Waveform Exam-
ple.vi).

The functionality was then added as saving data to �le and a while loop
around the existing program with a delay to save data. The whole function-
ality can be seen in �gure 4.10.
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Figure 4.10: Labview program to measure battery life

Figure 4.11 shows the measurement circuit to measure current consump-
tion and terminal voltage. The current consumption was measured only as
reference to �nd the minimum terminal voltage.
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Figure 4.11: Test circuit for battery life

Table 4.1 explains in more detail a certain block in �gure 4.11.

In �gure 4.12 a plot of terminal voltage over time is presented.

Figure 4.12: Terminal voltage over time for battery life

The batteries' life time lasted around 8 hours and 54 minutes according to
�gure 4.13, which shows when the nRF51822 development dongle PCA10000
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established and lost connection to the nRF51822 development kit PCB an-
tenna module PCA10004.

Figure 4.13: Master control panel for battery life

According to �gure 4.12 it shows that the voltage is dropped under 1,8V
after 9 hours and according to the reference [23], the supply voltage range is
1,8V to 3,6V when using the internal LDO regulator. However it is di�erent
from the simulated value in �gure 3.5 which can depend on theory of internal
resistance in chapter 2.2.1 which explains that internal resistance increases
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when battery ages and that phenomenon is not simulated in battery model
in �gure 3.1.

4.3 Conclusion measurements

• It has been shown that measurements, simulations and theory for the
functionality test are nearly similar.

• It has been shown that measurements and simulations for the battery
life is di�erent.

• It has been shown that simulations and theory for the battery life is
nearly similar.

It had been good to measure battery life according to simulation in �gure
3.2 and �gure 3.3. Both in a way to see that the batteries from Enfucell can
deliver the stated capacity, but also to calibrate the Labview measurement
program in �gure 4.10.
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5 Conclusion

It is possible to get the printed batteries to last better with a rather big
capacitor when the current reaches the peak value according to power man-
agement in chapter 4.1.

There are also limits, the terminal voltage lowest point can never be higher
than Udropaverage according to chapter 4.1. To get a better system from that
point of view the average current must be minimized in some way.

The life time of the battery is also limited according to chapter 4.2. To get
a better system from that point of view again the average current must be
minimized in some way.

One way to minimize the average current is to analyze the possibilities to
change time when the radio is in active mode and inactive mode according
to chapter 3.2.

55



6 Future work

The way to analyze the possibilities to change time when the radio is in
active mode and inactive mode should be prioritized.

To analyze how often units must communicate could be a future area to
research in. To investigate if it is possible to communicate in a more e�ective
way could also be done.

Future work is also to investigate and work together with the distributor of
the power source to see if it is some way that could be an improvement for
the application.

It can also be an idea to investigate e�ciency between the internal LDO
regulator in the application's radio and an external DC/DC-converter of
step-down type. The application's radio must then be run in low power
mode according to reference [20].
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Appendix

A Simulation in LTSpice

A.1 Battery model

1. Choose �File->New Schematic�.

2. Place all components and add parameters for all components according
to �gure A.1 and table A.1 (�Edit->Component�).

3. Draw wires between every components (�Edit->Draw wire�).

4. Label net with �port type� �output� (i.e. SOC, Anode and Cathode)
according to �gure A.1 (�Edit->Label net�).

5. Place ground symbols according to �gure A.1 (�Edit->Place GND�).

6. Choose �Edit->SPICE Directive� and write �.include Discharge_table.txt�.

7. Choose �Hierarchy->Open this Sheet's Symbol� - LTSpice will answer:
�Couldn't �nd this sheet's symbol. Shall I try to automatically generate
one?� - choose �YES�.

8. Choose �File->Save as� and choose name and directory of the project.

Figure A.1: Simulation circuit for battery model
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Component Parameter: value

cap Reference designator: C, Capacitance[F]:
{3600*CAPACITY*0.93} IC={INITSOC}

res Reference designator: R, Resistance[ohm]:
{SHELFLIFETIME*365*24/(CAPACITY*0.105)}

f Pre�x: G, Instname: CCCS, Value:
value={I(V_Sense)}

e Pre�x: X, Instname: VCVS, Value2: Discharge_table

e Pre�x: E, Instname: N_cell, Value: {CELLS}

voltage Reference designator: V_Sense, DC value[V]: 0

res Reference designator: Ri, Resistance[ohm]:
{RESISTANCE}

Table A.1: Components for battery model

A.2 Battery test

1. Choose �File->New Schematic�.

2. Choose �Edit->Component� and browse and choose the newly created
battery model component.

3. Add parameters for the battery model according to �gure A.2 and table
A.2.

4. Choose �Edit->Component� and browse and choose component �res�
and add parameters according to �gure A.2 and table A.2.

5. Draw wires between every components (�Edit->Draw wire�).

6. Label net with �port type� �none� (Terminal) according to �gure A.2
(�Edit->Label net�).

7. Place ground symbols according to �gure A.2 (�Edit->Place GND�).

8. Choose �Edit->SPICE Directive� and write �.opt plotwinsize=0�.

9. Choose �Edit->SPICE Directive� and write �.tran {3600*150} uic�.

10. Choose �Simulate->Run� and �point� at the label �Terminal� in the
schematic window - the result should be according to �gure 3.3.

11. Choose �File->Save as� and choose name and directory of the project.
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Figure A.2: Simulation circuit for Enfucell battery

Component Parameter: value

Battery
model

Instance name: X1, Params: CAPACITY=0.018
RESISTANCE=150 CELLS=1 INITSOC=1

SHELFLIFETIME=2

res Reference designator: R1, Resistance[ohm]: 10000

Table A.2: Components for battery test

A.3 Battery life

1. Choose �File->New Schematic�.

2. Choose �Edit->Component� and browse and choose the newly created
battery model component.

3. Add parameters for the battery model according to �gure A.3 and table
A.3.

4. Repeat point 2 and 3 two times.

5. Place all components and add parameters for all components according
to �gure A.3 and table A.3 (�Edit->Component�).

6. Draw wires between every components (�Edit->Draw wire�).

7. Label net with �port type� �none� (i.e Terminal and LDO) according
to �gure A.3 (�Edit->Label net�).

8. Place ground symbols according to �gure A.3 (�Edit->Place GND�).

9. Choose �Edit->SPICE Directive� and write �.opt plotwinsize=0�.
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10. Choose �Edit->SPICE Directive� and write �.tran {3600*150} uic�.

11. Choose �Simulate->Run� and �point� at the labels �Terminal� and
�LDO� and the current source with �reference designator� �Iradio� in
the schematic window - the result should be according to �gure 3.5.

12. Choose �File->Save as� and choose name and directory of the project.

Figure A.3: Simulation circuit for battery life
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Component Parameter: value

Battery
model

Instance name: X1, Params: CAPACITY=0.018
RESISTANCE=150 CELLS=1 INITSOC=1

SHELFLIFETIME=2

Battery
model

Instance name: X2, Params: CAPACITY=0.018
RESISTANCE=150 CELLS=1 INITSOC=1

SHELFLIFETIME=2

res Reference designator: RL, Resistance[ohm]: 5.6k

cap Reference designator: C, Capacitance[F]: 0.22m

Power
Products\
LT1761-

1.8

Reference designator: U1

cap Reference designator: C1, Capacitance[F]: 47n

current Reference designator: Iradio, DC value[A]: 0.39m

Table A.3: Components for battery life

A.4 Functionality test

1. Choose �File->New Schematic�.

2. Choose �Edit->Component� and browse and choose the newly created
battery model component.

3. Add parameters for the battery model according to �gure A.4 and table
A.4.

4. Repeat point 2 and 3 two times.

5. Place all components and add parameters for all components according
to �gure A.4 and table A.4 (�Edit->Component�).

6. Draw wires between every components (�Edit->Draw wire�).

7. Label net with �port type� �none� (i.e Terminal and LDO) according
to �gure A.4 (�Edit->Label net�).

8. Place ground symbols according to �gure A.4 (�Edit->Place GND�).

9. Choose �Edit->SPICE Directive� and write �.model MYSW SW(Ron=1
Ro�=1Meg Vt=.5 Vh=-.4)�.
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10. Choose �Edit->SPICE Directive� and write �.tran 0 4.048 4.008�.

11. Choose �Simulate->Run� and �point� at the labels �Terminal� and
�LDO� and the �reference designator� �Iradio� in the schematic win-
dow - the result should be according to �gure 3.9.

12. Choose �File->Save as� and choose name and directory of the project.

Figure A.4: Simulation circuit for functionality test
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Component Parameter: value

Battery
model

Instance name: X1, Params: CAPACITY=0.018
RESISTANCE=150 CELLS=1 INITSOC=0.937

SHELFLIFETIME=2

Battery
model

Instance name: X2, Params: CAPACITY=0.018
RESISTANCE=150 CELLS=1 INITSOC=0.937

SHELFLIFETIME=2

res Reference designator: RL, Resistance[ohm]: 5.6k

cap Reference designator: C, Capacitance[F]: 0.22m

sw Pre�x: S, Instname: S1, Value: MYSW

voltage Pre�x: V, Instname: V, Value: PWL REPEAT
FOREVER(+0.0000001m 0 +17.65 0 +0.0000001m 5

+2.35m 5)ENDREPEAT

Power
Products\
LT1761-

1.8

Reference designator: U1

cap Reference designator: C1, Capacitance[F]: 47n

current Pre�x: I, Instname: Iradio, Value: PWL REPEAT
FOREVER(+0.0000001m 0 +17.75 0 +0.0000001m 3.5m

+2.25m 3.5m)ENDREPEAT

Table A.4: Components for functionality test
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A.5 Look-up table

Data for the look-up table �Discharge_table.txt�:

;Enfucell soft battery Mini 1,5V

;x-axis calculated as 1-(xh/135h)

;Data: Capacity=0.018Ah, Rin=150ohm, Rload=10kohm

.SUBCKT Discharge_table 1 2 inv -inv

E_Cell 1 2 TABLE {V(inv,-inv)} =

+ (0.000 0.900) (0.037 1.020) (0.074 1.093)

+ (0.111 1.133) (0.148 1.160) (0.185 1.180)

+ (0.222 1.193) (0.259 1.200) (0.296 1.220)

+ (0.333 1.233) (0.370 1.240) (0.407 1.253)

+ (0.444 1.260) (0.481 1.267) (0.519 1.267)

+ (0.556 1.273) (0.593 1.280) (0.630 1.286)

+ (0.667 1.300) (0.704 1.320) (0.741 1.333)

+ (0.778 1.353) (0.815 1.380) (0.852 1.400)

+ (0.889 1.440) (0.926 1.486) (0.963 1.547)

+ (1.000 1.620)

.ENDS
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